$re = '/^[^.]*(?:(?:\.[^\.]*){0,1})$/m';
$str = 'lo.cat.tion
location
loca.tion
loca_caca
loca.cas.cas.acs
asd.asd.asas.asd.asd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);