// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^.]*(?:(?:\.[^\.]*){0,1})$").unwrap();
let string = "lo.cat.tion
location
loca.tion
loca_caca
loca.cas.cas.acs
asd.asd.asas.asd.asd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}