package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ABC|ABc|AbC|Abc|aBC|abC|abc`)
var str = `This should match:
ABC
ABc
AbC
Abc
aBC
abC
abc
Text with abc in it should also match. Even if it is within a word like in Barabc Obama.
This must not match:
aBc
cba
aaa
bbb
ccc
bac
ABBA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}