import re
regex = re.compile(r"ABC|ABc|AbC|Abc|aBC|abC|abc")
test_str = ("This should match:\n"
"ABC\n"
"ABc\n"
"AbC\n"
"Abc\n"
"aBC\n"
"abC\n"
"abc\n\n"
"Text with abc in it should also match. Even if it is within a word like in Barabc Obama.\n\n"
"This must not match:\n"
"aBc\n"
"cba\n"
"aaa\n"
"bbb\n"
"ccc\n"
"bac\n"
"ABBA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")