import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ABC|ABc|AbC|Abc|aBC|abC|abc";
final String string = "This should match:\n"
+ "ABC\n"
+ "ABc\n"
+ "AbC\n"
+ "Abc\n"
+ "aBC\n"
+ "abC\n"
+ "abc\n\n"
+ "Text with abc in it should also match. Even if it is within a word like in Barabc Obama.\n\n"
+ "This must not match:\n"
+ "aBc\n"
+ "cba\n"
+ "aaa\n"
+ "bbb\n"
+ "ccc\n"
+ "bac\n"
+ "ABBA";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}