using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=NM1\*03\*1\*).*?~((REF\*(?<refDepCode>\w{2,3})\*(?<refDepVal>.*?)~)*)";
string input = @"TRN*1*abc123*9999999999~NM1*03*1*SMITH*BOB*E~REF*6P*ABCDEF~REF*SY*123456789~N3*1234 MAIN ST~N4*SAN FRAN*CA*924102005~";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}