$re = '/(?=NM1\*03\*1\*).*?~((REF\*(?<refDepCode>\w{2,3})\*(?<refDepVal>.*?)~)*)/ms';
$str = 'TRN*1*abc123*9999999999~NM1*03*1*SMITH*BOB*E~REF*6P*ABCDEF~REF*SY*123456789~N3*1234 MAIN ST~N4*SAN FRAN*CA*924102005~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);