import Foundation
let pattern = #"(?=NM1\*03\*1\*).*?~((REF\*(?<refDepCode>\w{2,3})\*(?<refDepVal>.*?)~)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"TRN*1*abc123*9999999999~NM1*03*1*SMITH*BOB*E~REF*6P*ABCDEF~REF*SY*123456789~N3*1234 MAIN ST~N4*SAN FRAN*CA*924102005~"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)