import re
regex = re.compile(r"(?=NM1\*03\*1\*).*?~((REF\*(?<refDepCode>\w{2,3})\*(?<refDepVal>.*?)~)*)", flags=re.MULTILINE | re.DOTALL)
test_str = "TRN*1*abc123*9999999999~NM1*03*1*SMITH*BOB*E~REF*6P*ABCDEF~REF*SY*123456789~N3*1234 MAIN ST~N4*SAN FRAN*CA*924102005~"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")