# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n +(?=[[:alpha:]])/ /gm;t' <<< "this line
should be joined with this line
and with this line
but this line has a
0 at the front which is not alphabetic so should not be joined
0 an indented line
but what should happen here?"