import Foundation
let pattern = #"\n +(?=[[:alpha:]])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this line
should be joined with this line
and with this line
but this line has a
0 at the front which is not alphabetic so should not be joined
0 an indented line
but what should happen here?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)