#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\n +(?=[[:alpha:]])"
Local $sString = "this line" & @CRLF & _
" should be joined with this line" & @CRLF & _
" and with this line" & @CRLF & _
"" & @CRLF & _
"but this line has a" & @CRLF & _
" 0 at the front which is not alphabetic so should not be joined" & @CRLF & _
"" & @CRLF & _
" 0 an indented line" & @CRLF & _
" but what should happen here?"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)