re = /\n +(?=[[:alpha:]])/m
str = 'this line
should be joined with this line
and with this line
but this line has a
0 at the front which is not alphabetic so should not be joined
0 an indented line
but what should happen here?'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result