# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+\|\d+)|./\1/gm;t' <<< "Village_name(315|431 K64)"