$re = '/(\d+\|\d+)|./m';
$str = 'Village_name(315|431 K64)';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;