import re
regex = re.compile(r"(\d+\|\d+)|.", flags=re.MULTILINE)
test_str = "Village_name(315|431 K64)"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)