use strict;
my $str = 'Village_name(315|431 K64)';
my $regex = qr/(\d+\|\d+)|./mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";