#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.+)/(.+)(?:\.tar)?\.gz$"
Local $sString = "/path/to/file.txt.tar.gz" & @CRLF & _
"/path/to/file.txt.gz"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)