re = /^(.+)\/(.+)(?:\.tar)?\.gz$/m
str = '/path/to/file.txt.tar.gz
/path/to/file.txt.gz'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result