$re = '~^(.+)/(.+)(?:\.tar)?\.gz$~m';
$str = '/path/to/file.txt.tar.gz
/path/to/file.txt.gz';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;