const regex = new RegExp('^(.+)/(.+)(?:\\.tar)?\\.gz$', 'gm')
const str = `/path/to/file.txt.tar.gz
/path/to/file.txt.gz`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);