using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((https?|ftp):\/\/)?(www(\.|\%2[Ee]))?([a-zA-Z-]+(\.|\%2[Ee]))+([a-zA-Z-]{2,3}(?=\W|\b))([\/\?]\S*)*";
string input = @"something.This
something.Thi
youtube.com
youtube.comm";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}