re = /((https?|ftp):\/\/)?(www(\.|\%2[Ee]))?([a-zA-Z-]+(\.|\%2[Ee]))+([a-zA-Z-]{2,3}(?=\W|\b))([\/\?]\S*)*/
str = 'something.This
something.Thi
youtube.com
youtube.comm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end