import Foundation
let pattern = #"((https?|ftp):\/\/)?(www(\.|\%2[Ee]))?([a-zA-Z-]+(\.|\%2[Ee]))+([a-zA-Z-]{2,3}(?=\W|\b))([\/\?]\S*)*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
something.This
something.Thi
youtube.com
youtube.comm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)