const regex = /((https?|ftp):\/\/)?(www(\.|\%2[Ee]))?([a-zA-Z-]+(\.|\%2[Ee]))+([a-zA-Z-]{2,3}(?=\W|\b))([\/\?]\S*)*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((https?|ftp):\\\/\\\/)?(www(\\.|\\%2[Ee]))?([a-zA-Z-]+(\\.|\\%2[Ee]))+([a-zA-Z-]{2,3}(?=\\W|\\b))([\\\/\\?]\\S*)*', 'g')
const str = `something.This
something.Thi
youtube.com
youtube.comm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}