#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((([\w]+\S)@([a-zA-Z]*)(?!.))|((\d)+@([a-zA-Z]{4}+0[a-zA-Z0-9]{6}+)+.+IFSC+.NPCI))"
Local $sString = "anaghvj@yesbank.com" & @CRLF & _
"anaghvj@yesbank" & @CRLF & _
"123@yesbank" & @CRLF & _
"123@211.com" & @CRLF & _
"123.hdfc" & @CRLF & _
"123@HDFCBANK" & @CRLF & _
"anagh12@yesbank.com" & @CRLF & _
"123@ifsc.NPCI.UPI" & @CRLF & _
"1234" & @CRLF & _
"@dsds" & @CRLF & _
"sadasdsa.com" & @CRLF & _
"1234567@BARB0VNKOTA.IFSC.NPCI" & @CRLF & _
"12s2e3e@yebank.IFSC.NPCI" & @CRLF & _
"abnana@BARB0VNKOTA" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")