import re
regex = re.compile(r"((([\w]+\S)@([a-zA-Z]*)(?!.))|((\d)+@([a-zA-Z]{4}+0[a-zA-Z0-9]{6}+)+.+IFSC+.NPCI))")
test_str = ("anaghvj@yesbank.com\n"
"anaghvj@yesbank\n"
"123@yesbank\n"
"123@211.com\n"
"123.hdfc\n"
"123@HDFCBANK\n"
"anagh12@yesbank.com\n"
"123@ifsc.NPCI.UPI\n"
"1234\n"
"@dsds\n"
"sadasdsa.com\n"
"1234567@BARB0VNKOTA.IFSC.NPCI\n"
"12s2e3e@yebank.IFSC.NPCI\n"
"abnana@BARB0VNKOTA\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")