const regex = /((([\w]+\S)@([a-zA-Z]*)(?!.))|((\d)+@([a-zA-Z]{4}+0[a-zA-Z0-9]{6}+)+.+IFSC+.NPCI))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((([\\w]+\\S)@([a-zA-Z]*)(?!.))|((\\d)+@([a-zA-Z]{4}+0[a-zA-Z0-9]{6}+)+.+IFSC+.NPCI))', 'g')
const str = `anaghvj@yesbank.com
anaghvj@yesbank
123@yesbank
123@211.com
123.hdfc
123@HDFCBANK
anagh12@yesbank.com
123@ifsc.NPCI.UPI
1234
@dsds
sadasdsa.com
1234567@BARB0VNKOTA.IFSC.NPCI
12s2e3e@yebank.IFSC.NPCI
abnana@BARB0VNKOTA
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}