import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([\\w]+\\S)@([a-zA-Z]*)(?!.))|((\\d)+@([a-zA-Z]{4}+0[a-zA-Z0-9]{6}+)+.+IFSC+.NPCI))";
final String string = "anaghvj@yesbank.com\n"
+ "anaghvj@yesbank\n"
+ "123@yesbank\n"
+ "123@211.com\n"
+ "123.hdfc\n"
+ "123@HDFCBANK\n"
+ "anagh12@yesbank.com\n"
+ "123@ifsc.NPCI.UPI\n"
+ "1234\n"
+ "@dsds\n"
+ "sadasdsa.com\n"
+ "1234567@BARB0VNKOTA.IFSC.NPCI\n"
+ "12s2e3e@yebank.IFSC.NPCI\n"
+ "abnana@BARB0VNKOTA\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}