package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\?(.*)$`)
var str = `image/hugoboss/test%2Dimg?wid=100
image/hugoboss/test%2Dimg?wid=100&crop=0,0,960,650
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}