re = /\?(.*)$/m
str = 'image/hugoboss/test%2Dimg?wid=100
image/hugoboss/test%2Dimg?wid=100&crop=0,0,960,650
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end