// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\?(.*)$").unwrap();
let string = "image/hugoboss/test%2Dimg?wid=100
image/hugoboss/test%2Dimg?wid=100&crop=0,0,960,650
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}