const regex = /\bbrown\b[^o]*(?:o(?!ver\b)[^o]*)*\bover\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bbrown\\b[^o]*(?:o(?!ver\\b)[^o]*)*\\bover\\b', '')
const str = `The quick brown fox jumps over the lazy dog over.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}