re = /\bbrown\b[^o]*(?:o(?!ver\b)[^o]*)*\bover\b/
str = 'The quick brown fox jumps over the lazy dog over.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end