$re = '/\bbrown\b[^o]*(?:o(?!ver\b)[^o]*)*\bover\b/';
$str = 'The quick brown fox jumps over the lazy dog over.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);