#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(".*")"
Local $sString = ""http://g01.a.alicdn.com/kf/HTB1FGzVIpXXXXa3XFXXq6xXFXXXK/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg"," & @CRLF & _
""http://g03.a.alicdn.com/kf/HTB1YkHYIpXXXXcXXpXXq6xXFXXXg/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg"," & @CRLF & _
""http://g03.a.alicdn.com/kf/HTB1yS_0IpXXXXcQXpXXq6xXFXXX2/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg"," & @CRLF & _
""http://g02.a.alicdn.com/kf/HTB1fgIaIpXXXXXKXXXXq6xXFXXXV/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg"," & @CRLF & _
""http://g02.a.alicdn.com/kf/HTB1kpjVIpXXXXbhXFXXq6xXFXXXq/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")