package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(".*")`)
var str = `"http://g01.a.alicdn.com/kf/HTB1FGzVIpXXXXa3XFXXq6xXFXXXK/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g03.a.alicdn.com/kf/HTB1YkHYIpXXXXcXXpXXq6xXFXXXg/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g03.a.alicdn.com/kf/HTB1yS_0IpXXXXcQXpXXq6xXFXXX2/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g02.a.alicdn.com/kf/HTB1fgIaIpXXXXXKXXXXq6xXFXXXV/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g02.a.alicdn.com/kf/HTB1kpjVIpXXXXbhXFXXq6xXFXXXq/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}