use strict;
my $str = '"http://g01.a.alicdn.com/kf/HTB1FGzVIpXXXXa3XFXXq6xXFXXXK/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g03.a.alicdn.com/kf/HTB1YkHYIpXXXXcXXpXXq6xXFXXXg/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g03.a.alicdn.com/kf/HTB1yS_0IpXXXXcQXpXXq6xXFXXX2/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g02.a.alicdn.com/kf/HTB1fgIaIpXXXXXKXXXXq6xXFXXXV/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g02.a.alicdn.com/kf/HTB1kpjVIpXXXXbhXFXXq6xXFXXXq/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg"';
my $regex = qr/(".*")/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}