using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bv\d\.\d\.\d\b";
string input = @"ABCDEF v3.4.2 GHI KLMN donotv3.4.2capturethis";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}