package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bv\d\.\d\.\d\b`)
var str = `ABCDEF v3.4.2 GHI KLMN donotv3.4.2capturethis`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}