$re = '/\bv\d\.\d\.\d\b/';
$str = 'ABCDEF v3.4.2 GHI KLMN donotv3.4.2capturethis';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);