// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bv\d\.\d\.\d\b").unwrap();
let string = "ABCDEF v3.4.2 GHI KLMN donotv3.4.2capturethis";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}