using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]\d)\|(~?id\d+-(name\d+))(~?id\d+-(name\d+))?";
string input = @"1|a1|id11-name11,x|a2|id21-name21,y|a3|id31-name31~id32-name32";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}