$re = '/([a-zA-Z]\d)\|(~?id\d+-(name\d+))(~?id\d+-(name\d+))?/';
$str = '1|a1|id11-name11,x|a2|id21-name21,y|a3|id31-name31~id32-name32';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);