package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z]\d)\|(~?id\d+-(name\d+))(~?id\d+-(name\d+))?`)
var str = `1|a1|id11-name11,x|a2|id21-name21,y|a3|id31-name31~id32-name32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}