// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z]\d)\|(~?id\d+-(name\d+))(~?id\d+-(name\d+))?").unwrap();
let string = "1|a1|id11-name11,x|a2|id21-name21,y|a3|id31-name31~id32-name32";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}