import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^value:\\s?(\\S+(?:\\s[^-\\n]+)?)(?:\\s-\\s.*?-([^-\\n]*)(?:-.*)?)?$";
final String string = "value: 1.25MG - OM - PO/TUBE - ashaf\n"
+ "value:2.5 MG - OM - PO/TUBE -test\n"
+ "value: 18 UNITS(S)\n"
+ "value: 850 MG - TDS AFTER FOOD - SC (SUBCUTANE)\n"
+ "value: 75 MG - OM - PO/TUBE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}