re = /^value:\s?(\S+(?:\s[^-\n]+)?)(?:\s-\s.*?-([^-\n]*)(?:-.*)?)?$/m
str = 'value: 1.25MG - OM - PO/TUBE - ashaf
value:2.5 MG - OM - PO/TUBE -test
value: 18 UNITS(S)
value: 850 MG - TDS AFTER FOOD - SC (SUBCUTANE)
value: 75 MG - OM - PO/TUBE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end