import Foundation
let pattern = #"^value:\s?(\S+(?:\s[^-\n]+)?)(?:\s-\s.*?-([^-\n]*)(?:-.*)?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
value: 1.25MG - OM - PO/TUBE - ashaf
value:2.5 MG - OM - PO/TUBE -test
value: 18 UNITS(S)
value: 850 MG - TDS AFTER FOOD - SC (SUBCUTANE)
value: 75 MG - OM - PO/TUBE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)