using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\Q[SQLITE_CONSTRAINT_UNIQUE] \E(.*?)\Q (UNIQUE constraint failed\E";
string input = @"org.sqlite.SQLiteException: [SQLITE_CONSTRAINT_UNIQUE] A UNIQUE constraint failed (UNIQUE constraint failed Items.Name)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}